Skip to Content Information Center
Lexmark MS312

Lexmark MS312

Firmware upgrade reminders

Upgrade guidelines

  • This firmware release is intended for customers with current firmware versions LW73.xx.P034, LW72.xx.P030, LW71.xx.P025, LW70.xx.P022, or older (releases where the 2 digits immediately after LW are less than 70).
  • If the current firmware on the device is LW70.xx.P200 or newer (releases where the 3 digits after P are greater than 200), do NOT update to this release. Contact the Technical Support Center for a newer version of firmware.

MS310d, MS310dn, MS312dn, MS317, MS410d, and MS410dn devices

  • When updating from EC5 or older firmware to EC6 or newer firmware, use an intermediate release, LW50.PR.P593.FDN.PIR.E618.fls, included in the zip package along with these release notes.
  • If your device firmware is EC5 or older, update your device firmware first to LW50.PRL.P593. After your device reboots, you can proceed to update firmware to EC6.0 or newer firmware.
  • This intermediate update is necessary due to increased code size of EC6.0 or newer and memory usage during code updates. If you attempt to load EC6.0 or newer code over EC5 or older code other than LW50.PR.P593, it can take up to or more than 90 minutes to update or it may even fail completely due to an out of memory condition.

Non-eTask models

  • If your device was originally manufactured with EC1 code or earlier, it is possible that the DBCS (Japanese, Simplified Chinese, Traditional Chinese, and Korean) characters may go missing from the front panel display after updating firmware.
  • To fix this, simply send the updfonts.fls file included in the zip package to the device. This is a smaller version that fits in the space available with no loss of characters.

Downgrading to EC4.0 or EC4.05

  • Due to changes in EC4.0 and EC5, do NOT downgrade firmware from EC5 or newer directly to EC4.0 or EC4.05 based code. EC4.0 and EC4.05 code levels have names like LW40.xx.P4xx. This will cause a non-clearable 900 Service error. You will need to contact the TSC for instructions on how to clear this error.
  • This warning includes installing a DLE with EC4.0 or EC4.05 code into a device that currently has EC5 or newer code.
  • Code levels earlier than EC4.0 can be sent to EC5 level devices without causing a service error.
  • To downgrade EC5 or newer code to an EC4.0 or EC4.05 level, you must first load an EC4.1 based code. EC4.1 code levels have names like LW41.XX.P4xx. Once the device is at an EC4.1 level, EC4.0 code can be sent.
  • According to the firmware FAQ posted on our support site, we do not officially support downgrading firmware. This is the reason we do not support it, even though we go to great efforts to prevent these kinds of events from happening, sometimes it is unavoidable. We apologize for the inconvenience.

LEGACY ID: RE254

Was this article helpful?
Top